*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / media-gfx / inkscape / inkscape-9999.ebuild
index ba2909d315c4e50e181f0f3cdde7b2539c6d5abd..1a10390a90dcb2e7caff36cb165962e33576adbd 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
 PYTHON_REQ_USE="xml"
 MY_P="${P/_/}"
-inherit cmake-utils flag-o-matic xdg toolchain-funcs python-single-r1 git-r3
+inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1 git-r3
 
 DESCRIPTION="SVG based generic vector-drawing program"
 HOMEPAGE="https://inkscape.org/"
@@ -15,8 +15,8 @@ EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
 LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 KEYWORDS=""
-IUSE="cdr dbus dia exif gnome graphicsmagick imagemagick inkjar jemalloc jpeg
-lcms nls openmp postscript spell static-libs svg2 visio wpg"
+IUSE="cdr dbus dia exif graphicsmagick imagemagick inkjar jemalloc jpeg lcms nls
+openmp postscript spell static-libs svg2 visio wpg"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
@@ -58,7 +58,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
        )
        dbus? ( dev-libs/dbus-glib )
        exif? ( media-libs/libexif )
-       gnome? ( >=gnome-base/gnome-vfs-2.0 )
        imagemagick? (
                !graphicsmagick? ( <media-gfx/imagemagick-7:=[cxx] )
                graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
@@ -109,7 +108,7 @@ pkg_pretend() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
        sed -i "/install.*COPYING/d" CMakeScripts/ConfigCPack.cmake || die
 }
 
@@ -124,8 +123,8 @@ src_configure() {
                -DWITH_PROFILING=OFF
                -DWITH_LIBCDR=$(usex cdr)
                -DWITH_DBUS=$(usex dbus)
-               -DWITH_IMAGE_MAGICK=$(use imagemagick && use !graphicsmagick && echo "yes" || echo "no") # requires ImageMagick 6
-               -DWITH_GRAPHICS_MAGICK=$(usex graphicsmagick)
+               -DWITH_IMAGE_MAGICK=$(usex imagemagick $(usex !graphicsmagick)) # requires ImageMagick 6, only IM must be enabled
+               -DWITH_GRAPHICS_MAGICK=$(usex graphicsmagick $(usex imagemagick)) # both must be enabled to use GraphicsMagick
                -DWITH_JEMALLOC=$(usex jemalloc)
                -DENABLE_LCMS=$(usex lcms)
                -DWITH_NLS=$(usex nls)
@@ -136,11 +135,11 @@ src_configure() {
                -DWITH_LIBWPG=$(usex wpg)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        find "${ED}" -type f -name "*.la" -delete || die