*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / media-gfx / exiv2 / exiv2-0.27.2.ebuild
index 13352226a950d79f5d06721fb9683ebfbfffea8a..276e0c2eff313d4e65c9b880aaba02af9f0f049c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -8,10 +8,11 @@ if [[ ${PV} = *9999 ]]; then
        inherit git-r3
 else
        SRC_URI="https://exiv2.org/builds/${P}-Source.tar.gz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+       KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
 fi
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 inherit cmake-multilib python-any-r1
 
 DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
@@ -45,6 +46,8 @@ RDEPEND="${DEPEND}"
 
 DOCS=( README.md doc/ChangeLog doc/cmd.txt )
 
+PATCHES=( "${FILESDIR}/${P}-libssh-0.9.2.patch" )
+
 S="${S}-Source"
 
 pkg_setup() {
@@ -57,7 +60,7 @@ src_prepare() {
        iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
        mv -f doc/cmd.txt.tmp doc/cmd.txt || die
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
 }
@@ -77,11 +80,11 @@ multilib_src_configure() {
                -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        if multilib_is_native_abi; then
                use doc && eninja doc