mail-mta/postfix: migrate to sys-libs/pam
[gentoo.git] / mail-mta / postfix / postfix-2.10.9.ebuild
index a7d5a07d7893b7303b6ab5eb549933ce34700490..44058e81d3e5109432c5bd728d9c56e3c8254e4b 100644 (file)
@@ -1,6 +1,5 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
 inherit eutils multilib ssl-cert toolchain-funcs flag-o-matic pam user versionator systemd
@@ -19,7 +18,7 @@ SRC_URI="${MY_URI}/${MY_SRC}.tar.gz
 
 LICENSE="IBM"
 SLOT="0"
-KEYWORDS="~mips ~s390"
+KEYWORDS="~s390"
 IUSE="+berkdb cdb doc dovecot-sasl hardened ldap ldap-bind memcached mbox mysql nis pam postgres sasl selinux sqlite ssl vda"
 
 DEPEND=">=dev-libs/libpcre-3.4
@@ -29,11 +28,11 @@ DEPEND=">=dev-libs/libpcre-3.4
        ldap? ( net-nds/openldap )
        ldap-bind? ( net-nds/openldap[sasl] )
        mysql? ( virtual/mysql )
-       pam? ( virtual/pam )
+       pam? ( sys-libs/pam )
        postgres? ( dev-db/postgresql:* )
        sasl? (  >=dev-libs/cyrus-sasl-2 )
        sqlite? ( dev-db/sqlite:3 )
-       ssl? ( dev-libs/openssl:0 )"
+       ssl? ( dev-libs/openssl:0= )"
 
 RDEPEND="${DEPEND}
        dovecot-sasl? ( net-mail/dovecot )
@@ -296,20 +295,4 @@ pkg_postinst() {
                ewarn "work correctly without it."
                ewarn
        fi
-
-       if [[ $(get_version_component_range 2 ${REPLACING_VERSIONS}) -lt 9 ]]; then
-               elog "If you are using old style postfix instances by symlinking"
-               elog "startup scripts in ${ROOT}etc/init.d, please consider"
-               elog "upgrading your config for postmulti support. For more info:"
-               elog "http://www.postfix.org/MULTI_INSTANCE_README.html"
-               if ! use berkdb; then
-                       ewarn "\nPostfix is installed without BerkeleyDB support."
-                       ewarn "Please turn on berkdb USE flag if you need hash or"
-                       ewarn "btree table lookups.\n"
-               fi
-               ewarn "Postfix daemons now live under /usr/libexec/postfix"
-               ewarn "Please adjust your main.cf accordingly by running"
-               ewarn "etc-update/dispatch-conf or similar and accepting the new"
-               ewarn "daemon_directory setting."
-       fi
 }