*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / games-util / lutris / lutris-0.5.3.ebuild
index 7870d17a8ef34c15527a3b4be366ccdc256c6c63..4398b03d15de5e3793adb87929f1c38c6b2f1026 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
 PYTHON_REQ_USE="sqlite,threads(+)"
 
 inherit distutils-r1 virtualx xdg
@@ -38,7 +38,7 @@ RDEPEND="
        dev-python/python-evdev[${PYTHON_USEDEP}]
        dev-python/pyyaml[${PYTHON_USEDEP}]
        dev-python/requests[${PYTHON_USEDEP}]
-       gnome-base/gnome-desktop[introspection]
+       gnome-base/gnome-desktop:3[introspection]
        media-sound/fluid-soundfont
        net-libs/libsoup
        net-libs/webkit-gtk:4[introspection]
@@ -55,7 +55,7 @@ python_install_all() {
 }
 
 python_test() {
-       virtx nosetests -v || die
+       virtx nosetests -v
 }
 
 pkg_preinst() {