games-mud/gmudix: remove deprecated games eclass
[gentoo.git] / games-mud / gmudix / gmudix-1.0-r1.ebuild
diff --git a/games-mud/gmudix/gmudix-1.0-r1.ebuild b/games-mud/gmudix/gmudix-1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..75c2a1e
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="GTK+ MUD client with ANSI color, macros, timers, triggers, variables, and an easy scripting language"
+HOMEPAGE="http://dw.nl.eu.org/mudix.html"
+SRC_URI="http://dw.nl.eu.org/gmudix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-as-needed.patch
+       "${FILESDIR}"/${P}-format.patch
+)
+
+src_prepare() {
+       default
+
+       mv configure.in configure.ac || die
+       rm -f missing || die
+       eautoreconf
+}
+
+src_install() {
+       dobin src/${PN}
+       dodoc AUTHORS ChangeLog README TODO doc/*txt
+}