Fixes a bug inadvertently caused by 6c0a577 where setting update_seed
[catalyst.git] / examples / livecd-stage2_template.spec
index d185d34ab1d4682905df27bc7eb3f6695e1cb087..1a26bc615834bee348bfd1686160d2c6a0ffe465 100644 (file)
@@ -2,15 +2,15 @@
 # used to build a livecd-stage2 iso image
 
 # The subarch can be any of the supported catalyst subarches (like athlon-xp).
-# Refer to the catalyst reference manual for suppurted subarches.
-# http://www.gentoo.org/proj/en/releng/catalyst/reference.xml
+# Refer to "man catalyst" or <http://www.gentoo.org/proj/en/releng/catalyst/>
+# for supported subarches
 # example:
 # subarch: athlon-xp
 subarch:
 
 # The version stamp is an identifier for the build.  It can be anything you wish# it to be, but it is usually a date.
 # example:
-# version_stamp: 2005.0
+# version_stamp: 2006.1
 version_stamp:
 
 # The target specifies what target we want catalyst to do.  For building a CD,
@@ -28,18 +28,18 @@ rel_type:
 
 # This is the system profile to be used by catalyst to build this target.  It is# specified as a relative path from /usr/portage/profiles.
 # example:
-# profile: default-linux/x86/2005.0
+# profile: default-linux/x86/2006.1
 profile:
 
 # This specifies which snapshot to use for building this target.
 # example:
-# snapshot: 20050324
+# snapshot: 2006.1
 snapshot:
 
 # This specifies where the seed stage comes from for this target,  The path is
 # relative to $clst_sharedir/builds.  The rel_type is also used as a path prefix# for the seed.
 # example:
-# default/stage3-x86-2004.3
+# default/livecd-stage1-x86-2006.1
 source_subpath:
 
 # These are the hosts used as distcc slaves when distcc is enabled in your
@@ -56,30 +56,45 @@ distcc_hosts:
 # portage_confdir: /etc/portage
 portage_confdir:
 
-# The cdfstype is used to determine what sort of CD we should build.  This is
+# This option specifies the location to a portage overlay that you would like to
+# have used when building this target.
+# example:
+# portage_overlay: /usr/local/portage
+portage_overlay:
+
+# This allows the optional directory containing the output packages for
+# catalyst.  Mainly used as a way for different spec files to access the same
+# cache directory.  Default behavior is for this location to be autogenerated
+# by catalyst based on the spec file.
+# example:
+# pkgcache_path: /tmp/packages
+pkgcache_path:
+
+# This allows the optional directory containing the output packages for kernel
+# builds.  Mainly used as a way for different spec files to access the same
+# cache directory.  Default behavior is for this location to be autogenerated
+# by catalyst based on the spec file.
+# example:
+# kerncache_path: /tmp/kernel
+kerncache_path:
+
+# The fstype is used to determine what sort of CD we should build.  This is
 # used to set the type of loopback filesystem that we will use on our CD.
 # Possible options are as follows:
 # squashfs - This gives the best compression, but requires a kernel patch.
 # zisofs - This uses in-kernel compression and is supported on all platforms.
 # normal - This creates a loop without compression.
-# noloop - This copies the files to the CD directly, withuot using a loopback.
-# gcloop - This is deprecated and only provided for backwards compatibility.
-# example:
-# livecd/cdfstype: squashfs
-livecd/cdfstype:
-
-# The archscript is for architecture-dependent configuration.  Not all Gentoo
-# architectures use their own archscript.  Some share with other architectures
-# that are similar.
+# noloop - This copies the files to the CD directly, without using a loopback.
 # example:
-# livecd/archscript: /usr/lib/catalyst/livecd/runscript/x86-archscript.sh
-livecd/archscript:
+# livecd/fstype: squashfs
+livecd/fstype:
 
-# The runscript is the "brains" of the livecd-stage2 target and is designed to
-# be architecturer agnostic.  It is best not to change this.
+# The fsops are a list of optional parameters that can be passed to the tool
+# which will create the filesystem specified in livecd/fstype.  It is valid for
+# the following fstypes: squashfs, jffs, jffs2, cramfs
 # example:
-# livecd/runscript: /usr/lib/catalyst/livecd/runscript/default-runscript.sh
-livecd/runscript:
+# livecd/fsops: -root-owned
+livecd/fsops:
 
 # The cdtar is essentially the bootloader for the CD.  It also holds the main
 # configuration for the bootloader.  On x86/amd64, it also can include a small
@@ -95,7 +110,7 @@ livecd/cdtar:
 livecd/iso:
 
 # A fsscript is simply a shell script that is copied into the chroot of the CD
-# after the kernel(s) and any external modules have been compiled and is 
+# after the kernel(s) and any external modules have been compiled and is
 # executed within the chroot.  It can contain any commands that are available
 # via the packages installed by our stages or by the packages installed during
 # the livecd-stage1 build.  We do not use one for the official release media, so
@@ -106,26 +121,33 @@ livecd/iso:
 # livecd/fsscript:
 livecd/fsscript:
 
-# The splash type determines the automatic arguments for the bootloader on
-# supported architectures.  The possible options are gensplash and bootsplash.
+# This is where you set the splash theme.  This theme must be present in
+# /etc/splash, before the kernel has completed building.
 # example:
-# livecd/splash_type: gensplash
-livecd/splash_type:
+# livecd/splash_theme: livecd-2006.1
+livecd/splash_theme:
 
-# This is where you set the splash theme.  This theme must be present in either
-# /etc/splash or /etc/bootsplash, depending on your livecd/splash_type, before
-# the kernel has completed building during the livecd-stage2 target.
+# This is a set of arguments that get passed to the bootloader for your CD.  It
+# is used on the x86/amd64 release media to enable keymap selection.
 # example:
-# livecd/splash_theme: livecd-2005.0
-livecd/splash_theme:
+# livecd/bootargs: dokeymap
+livecd/bootargs:
 
 # This is a set of arguments that will be passed to genkernel for all kernels
 # defined in this target.  It is useful for passing arguments to genkernel that
 # are not otherwise available via the livecd-stage2 spec file.
 # example:
-# livecd/gk_mainargs: --lvm2 --dmraid
+# livecd/gk_mainargs: --lvm --dmraid
 livecd/gk_mainargs:
 
+# This option allows you to specify your own linuxrc script for genkernel to use
+# when building your CD.  This is not checked for functionality, so it is up to
+# you to debug your own script.  We do not use one for the official release
+# media, so there will not be one listed below.
+# example:
+# livecd/linuxrc:
+livecd/linuxrc:
+
 # This option controls quite a bit of catalyst internals and sets up several
 # defaults.  Each type behaves slightly differently and is explained below.
 # gentoo-release-minimal - This creates an official minimal InstallCD.
@@ -137,6 +159,14 @@ livecd/gk_mainargs:
 # livecd/type: gentoo-release-minimal
 livecd/type:
 
+# This is for the README.txt on the root of the CD.  For Gentoo releases, we
+# use a default README.txt, and this will be used on your CD if you do not
+# provide one yourself.  Since we do not use this for the official releases, it
+# is left blank below.
+# example:
+# livecd/readme:
+livecd/readme:
+
 # This is for the CD's message of the day.  It is not required for official
 # release media, as catalyst builds a default motd when the livecd/type is set
 # to one of the gentoo-* options.  This setting overrides the default motd even
@@ -154,10 +184,11 @@ livecd/motd:
 livecd/modblacklist:
 
 # This is for adding init scripts to runlevels.  The syntax for the init script
-# is the script name, followed by a colon, followed by the runlevel in which you
-# want the script to run.  It looks like spind:default and is space delimited.
+# is the script name, followed by a pipe, followed by the runlevel in which you
+# want the script to run.  It looks like spind|default and is space delimited.
 # We do not use this on the official media, as catalyst sets up the runlevels
 # correctly for us.  Since we do not use this, it is left blank below.
+# This option will automatically create missing runlevels
 # example:
 # livecd/rcadd:
 livecd/rcadd:
@@ -173,13 +204,12 @@ livecd/rcdel:
 
 # This overlay is dropped onto the CD filesystem and is outside any loop which
 # has been configured.  This is typically used for adding the documentation,
-# distfiles, snapshots, and stages to the official media.  These files will not 
+# distfiles, snapshots, and stages to the official media.  These files will not
 # be available if docache is enabled, as they are outside the loop.
 # example:
 # livecd/overlay: /tmp/overlay-minimal
 livecd/overlay:
 
-
 # This overlay is dropped onto the filesystem within the loop.  This can be used
 # for such things as updating configuration files or adding anything else you
 # would want within your CD filesystem.  Files added here are available when
@@ -189,13 +219,6 @@ livecd/overlay:
 # livecd/root_overlay:
 livecd/root_overlay:
 
-# This is here to enable udev support in both catalyst and genkernel.  This
-# option requires genkernel >= 3.1.0, and is not needed with genkernel >=3.2.0,
-# as udev is the default.
-# example:
-# livecd/devmanager: udev
-livecd/devmanager:
-
 # This is used by catalyst to copy the specified file to /etc/X11/xinit/xinitrc
 # and is used by the livecd/type gentoo-gamecd and generic-livecd.  While the
 # file will still be copied for any livecd/type, catalyst will only create the
@@ -206,6 +229,34 @@ livecd/devmanager:
 # livecd/xinitrc:
 livecd/xinitrc:
 
+# This is used by catalyst to determine which display manager you wish to
+# become the default.  This is used on the official Gentoo LiveCD and is valid
+# for any livecd/type.
+# example:
+# livecd/xdm: gdm
+livecd/xdm:
+
+# This is used by catalyst to determine which X session should be started by
+# default by the display manager.  This is used on the official Gentoo LiveCD
+# and is valid for any livecd/type.
+# example:
+# livecd/xsession: gnome
+livecd/xsession:
+
+# This option is used to create non-root users on your CD.  It takes a space
+# separated list of user names.  These users will be added to the following
+# groups: users,wheel,audio,games,cdrom,usb
+# If this is specified in your spec file, then the first user is also the user
+# used to start X. Since this is not used on the release media, it is blank.
+# example:
+# livecd/users:
+livecd/users:
+
+# This option sets the volume ID of the CD created.
+# example:
+# livecd/volid: Gentoo Linux 2006.1 X86
+livecd/volid:
+
 # This option is only used when creating a GameCD.  This specifies the file that
 # contains the definitions for GAME_NAME and GAME_EXECUTABLE, which are used by
 # the GameCD scripts to set some specific options for the game.  This is not
@@ -257,24 +308,31 @@ boot/kernel/gentoo/use:
 # boot/kernel/gentoo/extraversion:
 boot/kernel/gentoo/extraversion:
 
-# This option is a list of packages which genkernel will emerge after the kernel
-# has been configured, but before it is compiled.  This option is used for the
-# exclusive purpose of including our gensplash theme into the kernel bzImage.
-# example:
-# boot/kernel/gentoo/postconf: splashutils splash-themes-livecd
-boot/kernel/gentoo/postconf:
-
 # This option is for merging kernel-dependent packages and external modules that
 # are configured against this kernel label.
 # example:
 # boot/kernel/gentoo/packages: pcmcia-cs speedtouch slmodem globespan-adsl hostap-driver hostap-utils ipw2100 ipw2200 fritzcapi fcdsl cryptsetup
 boot/kernel/gentoo/packages:
 
+# This option is only for ppc64 machines.  If used it will create the /etc/yaboot.conf
+# entry used for booting a ibm powerpc machine.
+# example:
+# boot/kernel/gentoo/machine_type: ibm
+boot/kernel/gentoo/machine_type:
+
+# This is only supported on ppc64 currently.  This entry sets up the console=
+# boot parameters required for sending the output to the appropriate console.
+# example:
+# boot/kernel/gentoo/console: hvsi0
+# boot/kernel/gentoo/console: hvc0
+# boot/kernel/gentoo/console: tty0 ttyS0
+boot/kernel/gentoo/console:
+
 # This is a list of packages that will be unmerged after all the kernels have
 # been built.  There are no checks on these packages, so be careful what you
 # add here.  They can potentially break your CD.
 # example:
-# livecd/unmerge: acl attr autoconf automake bin86 binutils libtool m4 bison ld.so make perl patch linux-headers man-pages sash bison flex gettext texinfo ccache distcc addpatches man groff lib-compat miscfiles rsync sysklogd bc lcms libmng genkernel diffutils libperl gnuconfig gcc-config gcc bin86 cpio cronbase ed expat grub lilo help2man libtool gentoo-sources
+# livecd/unmerge: acl attr autoconf automake bin86 binutils libtool m4 bison ld.so make perl patch linux-headers man-pages sash bison flex gettext texinfo ccache distcc man groff lib-compat miscfiles rsync sysklogd bc lcms libmng genkernel diffutils libperl gnuconfig gcc-config gcc bin86 cpio cronbase ed expat grub lilo help2man libtool gentoo-sources
 livecd/unmerge:
 
 # This option is used to empty the directories listed.  It is useful for getting
@@ -287,5 +345,5 @@ livecd/empty:
 # This option tells catalyst to clean specific files from the filesystem and is
 # very usefu in cleaning up stray files in /etc left over after livecd/unmerge.
 # example:
-# livecd/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/bootsplash* /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2005.0/16* /etc/splash/livecd-2005.0/12* /etc/splash/livecd-2005.0/6* /etc/splash/livecd-2005.0/8* /etc/splash/livecd-2005.0/images/silent-16* /etc/splash/livecd-2005.0/images/silent-12* /etc/splash/livecd-2005.0/images/silent-6* /etc/splash/livecd-2005.0/images/silent-8* /etc/splash/livecd-2005.0/images/verbose-16* /etc/splash/livecd-2005.0/images/verbose-12* /etc/splash/livecd-2005.0/images/verbose-6* /etc/splash/livecd-2005.0/images/verbose-8* /etc/make.conf.example /etc/make.globals /etc/resolv.conf
+# livecd/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/portage/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/bootsplash* /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2006.1/16* /etc/splash/livecd-2006.1/12* /etc/splash/livecd-2006.1/6* /etc/splash/livecd-2006.1/8* /etc/splash/livecd-2006.1/images/silent-16* /etc/splash/livecd-2006.1/images/silent-12* /etc/splash/livecd-2006.1/images/silent-6* /etc/splash/livecd-2006.1/images/silent-8* /etc/splash/livecd-2006.1/images/verbose-16* /etc/splash/livecd-2006.1/images/verbose-12* /etc/splash/livecd-2006.1/images/verbose-6* /etc/splash/livecd-2006.1/images/verbose-8* /etc/portage/make.conf.example /etc/make.globals /etc/resolv.conf
 livecd/rm: