dev-vcs/gitstats: fix the live ebuild's repo URI, license, dependencies, docs
[gentoo.git] / dev-vcs / gitstats / gitstats-9999.ebuild
index 06a43c4884dc08d0b1ffef2811c6f7f3bc9dd6d9..eddba33fc5476b484b8c61dd7067a229ab7662e2 100644 (file)
@@ -1,21 +1,22 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit python-r1 git-2
+inherit python-r1 git-r3
 
 DESCRIPTION="Statistics generator for git"
 HOMEPAGE="http://gitstats.sourceforge.net/"
 SRC_URI=""
 EGIT_REPO_URI="
-       git://repo.or.cz/${PN}.git
-       http://repo.or.cz/r/${PN}.git"
+       git://github.com/hoxu/gitstats.git
+       https://github.com/hoxu/gitstats.git
+"
 
-LICENSE="GPL-3"
+LICENSE="|| ( GPL-2 GPL-3 ) MIT"
 SLOT="0"
 KEYWORDS=""
 IUSE=""
@@ -23,20 +24,26 @@ IUSE=""
 RDEPEND="
        sci-visualization/gnuplot[gd]
        dev-vcs/git"
-DEPEND=""
+DEPEND="
+       dev-lang/perl:*
+"
+
+DOCS=( doc/{AUTHOR,README,TODO.txt} )
 
 src_prepare() {
        sed \
-               -e "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '${EPREFIX}/usr/share/gitstats':g" \
+               -e "s:basedirs = \[binarypath, secondarypath, '/usr/share/gitstats'\]:basedirs = \['${EPREFIX}/usr/share/gitstats'\]:g" \
        -i gitstats || die "failed to fix static files path"
+       default
 }
 
 src_compile() {
-       :;
+       emake VERSION="${PV}" man
 }
 
 src_install() {
-       emake PREFIX="${D}"/usr VERSION="${PV}" install
-       dodoc doc/{README,*.txt}
-       python_replicate_script "${ED}"/usr/bin/${PN}
+       emake PREFIX="${ED}"usr VERSION="${PV}" install
+       doman doc/${PN}.1
+       einstalldocs
+       python_replicate_script "${ED}"usr/bin/${PN}
 }