*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-vcs / git / git-2.23.0-r1.ebuild
index ec95d334218d1cd4382420dc21ae67f807705c80..a8dd71b1c38394ebd531542e98c751404cf2f344 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
 GENTOO_DEPEND_ON_PERL=no
 
 # bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
 
 inherit toolchain-funcs elisp-common l10n perl-module bash-completion-r1 python-single-r1 systemd
 
@@ -46,12 +46,12 @@ if [[ ${PV} != *9999 ]]; then
                        ${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
                        )"
        [[ "${PV}" == *_rc* ]] || \
-       KEYWORDS="alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+       KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl +ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
@@ -69,7 +69,7 @@ CDEPEND="
                net-misc/curl
                webdav? ( dev-libs/expat )
        )
-       emacs? ( virtual/emacs )
+       emacs? ( >=app-editors/emacs-23.1:* )
        iconv? ( virtual/libiconv )
 "
 
@@ -136,6 +136,8 @@ REQUIRED_USE="
        perforce? ( ${PYTHON_REQUIRED_USE} )
 "
 
+RESTRICT="!test? ( test )"
+
 PATCHES=(
        # bug #350330 - automagic CVS when we don't want it is bad.
        "${FILESDIR}"/git-2.22.0_rc0-optional-cvs.patch
@@ -543,7 +545,7 @@ src_install() {
                # but upstream installs in /usr/share/gitweb
                # so we will install a symlink and use their location for compat with other
                # distros
-               dosym /usr/share/gitweb /usr/share/${PN}/gitweb
+               dosym ../gitweb /usr/share/${PN}/gitweb
 
                # INSTALL discusses configuration issues, not just installation
                docinto /