*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / wstool / wstool-9999.ebuild
index d8ec14af3a9d2ca375dece9f2f304adc0c0c3c4b..6dbe2958bdb9e5cd2bfe23b8ca8d18de7437fd32 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
 
 SCM=""
 if [ "${PV#9999}" != "${PV}" ] ; then
@@ -20,7 +19,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
        KEYWORDS=""
 else
        SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
-               http://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+               https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
        "
        KEYWORDS="~amd64 ~arm"
 fi
@@ -28,6 +27,7 @@ fi
 LICENSE="BSD"
 SLOT="0"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        dev-python/pyyaml[${PYTHON_USEDEP}]
@@ -45,7 +45,6 @@ DEPEND="${RDEPEND}
        )
 "
 
-PATCHES=( "${FILESDIR}/prefix.patch" )
 DISTUTILS_IN_SOURCE_BUILD="yes"
 
 python_test() {