*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / wstool / wstool-9999.ebuild
index aaee65031a12173c30c2f5945bdff6c8728fc991..6dbe2958bdb9e5cd2bfe23b8ca8d18de7437fd32 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
 
 SCM=""
 if [ "${PV#9999}" != "${PV}" ] ; then
@@ -28,6 +27,7 @@ fi
 LICENSE="BSD"
 SLOT="0"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        dev-python/pyyaml[${PYTHON_USEDEP}]
@@ -45,7 +45,6 @@ DEPEND="${RDEPEND}
        )
 "
 
-PATCHES=( "${FILESDIR}/prefix2.patch" )
 DISTUTILS_IN_SOURCE_BUILD="yes"
 
 python_test() {