dev-util/kbuild: Don't build with distcc
[gentoo.git] / dev-util / kbuild / kbuild-9999.ebuild
index ccbf4507612e1dfdef8b2c5e1319c83407e9cc90..ac794242d86c6822cffccc26ab1f86ea47a2cbf0 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -20,6 +20,11 @@ RDEPEND=""
 
 S="${WORKDIR}/${MY_P/-src}"
 
+pkg_setup() {
+       # Package fails with distcc (bug #255371)
+       export DISTCC_DISABLE=1
+}
+
 src_prepare() {
        default
        rm -rf "${S}/kBuild/bin" || die