dev-util/kbuild: Don't build with distcc
[gentoo.git] / dev-util / kbuild / kbuild-0.1.9998.3149.ebuild
index 7c358202b8854e6d3759b3ef13af36bc9e1ccb6a..4ed9922800e38339e8c67eefb0e287f2be5f5384 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -32,6 +32,11 @@ PATCHES=(
        "${FILESDIR}/${PN}-0.1.9998_pre20171020-gold.patch"
 )
 
+pkg_setup() {
+       # Package fails with distcc (bug #255371)
+       export DISTCC_DISABLE=1
+}
+
 src_prepare() {
        rm -rf "${S}/kBuild/bin"