dev-util/gyp: Use Python 3.
[gentoo.git] / dev-util / gyp / gyp-99999999999999.ebuild
index 062dcc113759a050e1968ef2e6b887110519362c..da57f66635d9f62d871db68b66d824b8179a7a0c 100644 (file)
@@ -1,9 +1,10 @@
-# Copyright 2017-2019 Gentoo Authors
+# Copyright 2017-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="7"
-PYTHON_COMPAT=(python2_7)
+PYTHON_COMPAT=(python{3_6,3_7})
 DISTUTILS_SINGLE_IMPL="1"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
 
 inherit distutils-r1
 
@@ -25,12 +26,10 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS=""
 IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
-BDEPEND="${PYTHON_DEPS}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND=""
 DEPEND=""
-RDEPEND="${BDEPEND}"
+RDEPEND=""
 
 src_test() {
        # More errors when DeprecationWarnings enabled.