dev-python/objgraph: keyworded 3.4.1 for ia64, bug #717946
[gentoo.git] / dev-util / google-perftools / google-perftools-2.6.2.ebuild
index 2693c942343a61335bf88f85f0489d373651d6e2..9d06795756895285c1d8bd7274f1bb9b1ae855b8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -8,7 +8,7 @@ inherit toolchain-funcs flag-o-matic vcs-snapshot autotools multilib-minimal
 
 DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
 HOMEPAGE="https://github.com/gperftools/gperftools"
-SRC_URI="https://github.com/gperftools/gperftools/tarball/${MY_P} -> ${MY_P}.tar.gz"
+SRC_URI="https://github.com/gperftools/gperftools/archive/${MY_P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="0/4"
@@ -17,8 +17,9 @@ SLOT="0/4"
 # linux x86/amd64/ppc/ppc64/arm
 # OSX ppc/amd64
 # AIX ppc/ppc64
-KEYWORDS="-* ~amd64 ~arm ~arm64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="-* amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
 IUSE="largepages +debug minimal optimisememory test static-libs"
+RESTRICT="!test? ( test )"
 
 DEPEND="sys-libs/libunwind"
 RDEPEND="${DEPEND}"
@@ -51,8 +52,6 @@ multilib_src_configure() {
        append-flags -fno-strict-aliasing -fno-omit-frame-pointer
 
        econf \
-               --htmldir=${EPREFIX}/usr/share/doc/${PF}/html \
-               --docdir=${EPREFIX}/usr/share/doc/${PF} \
                --enable-shared \
                $(use_enable static-libs static) \
                $(use_enable debug debugalloc) \