dev-util/clinfo: 2.2.18.03.26 version bump
[gentoo.git] / dev-util / clinfo / clinfo-2.2.18.03.26.ebuild
diff --git a/dev-util/clinfo/clinfo-2.2.18.03.26.ebuild b/dev-util/clinfo/clinfo-2.2.18.03.26.ebuild
new file mode 100644 (file)
index 0000000..3d01e88
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+       inherit git-r3
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=app-eselect/eselect-opencl-1.1.0-r4
+       virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+       emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}