dev-ros/rotate_recovery: Bump to 1.15.2.
[gentoo.git] / dev-ros / rotate_recovery / rotate_recovery-1.15.2.ebuild
diff --git a/dev-ros/rotate_recovery/rotate_recovery-1.15.2.ebuild b/dev-ros/rotate_recovery/rotate_recovery-1.15.2.ebuild
new file mode 100644 (file)
index 0000000..f66e208
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by performing a 360 degree rotation of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roscpp
+       dev-ros/tf
+       dev-ros/costmap_2d
+       dev-ros/nav_core
+       dev-ros/pluginlib
+       dev-ros/base_local_planner
+       dev-cpp/eigen:3
+       dev-libs/boost:=
+       dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+       dev-ros/cmake_modules"