*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / mavros / mavros-9999.ebuild
index 8d05cde8c533fa867955bcd6379d2ce8d7c458ae..06d13ec84a26c8e5c5d537db0e1375271e10e615 100644 (file)
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
 ROS_REPO_URI="https://github.com/mavlink/mavros"
 KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
 ROS_SUBDIR=${PN}
 
 inherit ros-catkin
@@ -18,6 +17,7 @@ IUSE=""
 RDEPEND="
        dev-ros/diagnostic_updater
        dev-ros/pluginlib
+               dev-libs/tinyxml2:=
        dev-ros/roscpp
        dev-ros/tf
        dev-ros/angles
@@ -33,5 +33,6 @@ RDEPEND="
        dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        >=dev-ros/mavlink-gbp-release-2016.11.11
+       dev-libs/console_bridge:=
 "
 DEPEND="${RDEPEND}"