dev-python/entrypoints: Set DISTUTILS_USE_SETUPTOOLS
[gentoo.git] / dev-python / entrypoints / entrypoints-0.3-r1.ebuild
index 4543153682553bfb02bb0364168e7870c07f395c..2f28407b7f56f586e72302554c1668af64db8eec 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=no
 PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
 
 inherit distutils-r1
@@ -13,11 +14,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~sparc ~x86"
+KEYWORDS="amd64 ~arm arm64 ~ia64 ~sparc ~x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
@@ -25,8 +26,6 @@ DEPEND="
        )
 "
 
-RESTRICT="!test? ( test )"
-
 PATCHES=(
        "${FILESDIR}/${PN}"-0.2.1-init.py.patch
 )