*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / docker-py / docker-py-2.7.0.ebuild
index df541cde5208692e5a6c47d8d2902a01ae06b599..991185bd41009f9b54476b819db4481feaef1a07 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_6} )
 
 inherit distutils-r1
 
@@ -14,6 +14,7 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64 ~x86"
 IUSE="doc test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/docker-pycreds-0.2.1[${PYTHON_USEDEP}]
@@ -21,7 +22,7 @@ RDEPEND="
        >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
        >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
        $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
 "
 DEPEND="