Merge remote-tracking branch 'origin/dev-python/dj-search-url'
[wtk-overlay.git] / dev-python / dj-search-url / dj-search-url-9999.ebuild
diff --git a/dev-python/dj-search-url/dj-search-url-9999.ebuild b/dev-python/dj-search-url/dj-search-url-9999.ebuild
new file mode 100644 (file)
index 0000000..441feaa
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+       inherit git-2
+       EGIT_REPO_URI="git://github.com/dstufft/${PN}.git"
+       SRC_URI=""
+else
+       SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="Use Search URLs in your Django Haystack Application"
+HOMEPAGE="http://github.com/dstufft/dj-search-url https://pypi.python.org/pypi/dj-search-url"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-python/django[${PYTHON_USEDEP}]
+       "
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       "