Update URLs from einstein to tremily.
[wtk-overlay.git] / dev-python / curses-check-for-keypress / curses-check-for-keypress-9999.ebuild
index 03012441638a2acd1422aa642b16a7c3e6ec11bf..e65db12b63d052c4efd5cf9b4a0e0899d3ea2a02 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="3"
+EAPI="4"
 PYTHON_DEPEND="2:2.6"
 SUPPORT_PYTHON_ABIS="1"
 RESTRICT_PYTHON_ABIS="3.*"
@@ -12,24 +12,24 @@ inherit eutils distutils
 MY_PN="curses_check_for_keypress" #${PN/-/_}"
 
 if [[ ${PV} == "9999" ]] ; then
-       inherit git
-       EGIT_REPO_URI="http://www.physics.drexel.edu/~wking/code/git/${MY_PN}.git"
+       inherit git-2
+       EGIT_REPO_URI="git://tremily.us/${MY_PN}.git"
        SRC_URI=""
 else
-       SRC_URI="http://www.physics.drexel.edu/~wking/code/got/gitweb.cgi?p=${MY_PN}.git;a=snapshot;h=v${PV};sf=tgz"
+       SRC_URI="http://git.tremily.us/?p=${MY_PN}.git;a=snapshot;h=v${PV};sf=tgz"
 fi
 
 DESCRIPTION="Split **kwargs arguments among several functions."
-HOMEPAGE="http://www.physics.drexel.edu/~wking/unfolding-disasters/posts/${MY_PN}/"
+HOMEPAGE="http://blog.tremily.us/posts/${MY_PN}/"
 
 LICENSE="public-domain"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
 IUSE="test"
 
 src_unpack() {
        if [[ ${PV} == "9999" ]] ; then
-               git_src_unpack
+               git-2_src_unpack
        else
                unpack ${A}
        fi