*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / colorama / colorama-0.4.1.ebuild
index 9985605f1be310d6e2584e51cac9dcbe3a52ef8f..2301275f7c8c7290fdb851481b7dc79bf7268899 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
 
 inherit distutils-r1
 
@@ -17,8 +17,9 @@ SRC_URI="https://github.com/tartley/${PN}/archive/${PV}.tar.gz -> ${P}.github.ta
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
 IUSE="examples test"
+RESTRICT="!test? ( test )"
 
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]