*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / cliff / cliff-2.12.0.ebuild
index 982051ba5b1a047e303a46b414e4dfa0da2aaf79..89202b961400ee389f30d432ce7a5c5b775fa2e8 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -13,7 +13,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64 arm64 hppa ~mips s390 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+IUSE="test"
+RESTRICT="!test? ( test )"
 
 CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
        !~dev-python/pbr-2.1.0"
@@ -30,9 +31,6 @@ DEPEND="
                >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
                !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
        )
-       doc? (
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-       )
 "
 # source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
 RDEPEND="
@@ -47,15 +45,6 @@ RDEPEND="
        >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
        "
 
-python_compile() {
-       use doc && esetup.py build_sphinx
-}
-
 python_test() {
        nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
 }
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-       distutils-r1_python_install_all
-}