*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / blinker / blinker-1.4-r1.ebuild
index f46df4441e4b77eaf505151905ea192c4b01825f..08fd2f556b42aa50162d36eab29a301e8734f103 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
 
 inherit distutils-r1
 
@@ -13,14 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
 
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_test() {
-       nosetests -v || die "Testing failed with ${EPYTHON}"
-}
+distutils_enable_tests nose
 
 python_install_all() {
        use doc && HTML_DOCS=( docs/html/. )