*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / bleach / bleach-3.0.2.ebuild
index 5c77262f9cffecee58e751375e7806cd430a2871..92887bd8f5a2b5b8dea56736193e1db14de91460 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
 
 inherit distutils-r1
 
@@ -12,8 +12,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        dev-python/six[${PYTHON_USEDEP}]