*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / beautifulsoup / beautifulsoup-4.5.1.ebuild
index 2ff59864aee0e219136a58b35ef83e914887310b..62ce34be602eeee8f79558fc07a89616617d5ed7 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
 
 inherit distutils-r1
 
@@ -12,14 +12,15 @@ MY_P=${MY_PN}-${PV}
 
 DESCRIPTION="Provides pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
 HOMEPAGE="https://bugs.launchpad.net/beautifulsoup/
-       https://pypi.org/project/beautifulsoup4"
+       https://pypi.org/project/beautifulsoup4/"
 SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="4"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
 
 IUSE="doc test"
+RESTRICT="!test? ( test )"
 
 # html5lib is optional however hard coding since its use is actively discouraged in the devmanual
 RDEPEND="