*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / autopep8 / autopep8-1.3.3.ebuild
index 6e4372f597d252a4912b64b2b058c94371db8de6..2c90a97d42d828082b3175676613e12e9da33f73 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-PYTHON_COMPAT=( python{2_7,3_{5,6}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
 PYTHON_REQ_USE="threads(+)"
 
 inherit distutils-r1
@@ -21,6 +21,7 @@ fi
 LICENSE="MIT"
 SLOT="0"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]