*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / autopep8 / autopep8-1.3.3.ebuild
index 32c6043fa952938279da6d3c8ca5d1aeb8ece768..2c90a97d42d828082b3175676613e12e9da33f73 100644 (file)
@@ -1,21 +1,27 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
 PYTHON_REQ_USE="threads(+)"
 
 inherit distutils-r1
 
 DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]