*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / autobahn / autobahn-17.5.1-r2.ebuild
index 99f17355536553570894e44626bab8ce8082fd09..7a621b460ede5c140e4c36db03415a14a21b38b8 100644 (file)
@@ -1,22 +1,25 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_6 )
 
 inherit distutils-r1 versionator
 
 MY_P="${PN}-$(replace_version_separator 3 -)"
 
 DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
-HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
+HOMEPAGE="https://pypi.org/project/autobahn/
+       https://crossbar.io/autobahn/
+       https://github.com/crossbario/autobahn-python"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
 
 SLOT="0"
 LICENSE="MIT"
-KEYWORDS="~amd64"
+KEYWORDS="amd64 x86"
 IUSE="crypt test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        $(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' 'python2_7')