*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / astropy / astropy-1.3.3.ebuild
index b1a454a4e082822cc21453466bbb201c50e9881e..924aeef85f40566aa98e963be679720f19e99cae 100644 (file)
@@ -1,20 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
 
 inherit distutils-r1 xdg-utils
 
 DESCRIPTION="Core functionality for performing astrophysics with Python"
-HOMEPAGE="http://astropy.org/"
+HOMEPAGE="https://www.astropy.org/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="doc test"
+RESTRICT="!test? ( test )"
 
 # ply-3.10 incompatible, keep bundled (bug #622802)
 #rdep: dev-python/ply[${PYTHON_USEDEP}]