dev-python/asset: Remove py2
[gentoo.git] / dev-python / asset / asset-0.6.11.ebuild
index d39b012f5f0ac82b5b706c02c2c4db7b6ece874c..9143bf0f7aec508537d0dba82fbf6168d78ba0ce 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1
 
@@ -15,6 +15,7 @@ SLOT="0"
 LICENSE="GPL-3+"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/aadict-0.2.2[${PYTHON_USEDEP}]