*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / apipkg / apipkg-1.4.ebuild
index 4baead081ab9811c1ae24315c49a9c49a8e712e3..bdd563fb5f6373423cc3cf26e8f25eb9ad719789 100644 (file)
@@ -1,20 +1,20 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
 
 inherit distutils-r1
 
 DESCRIPTION="namespace control and lazy-import mechanism"
-HOMEPAGE="https://pypi.python.org/pypi/apipkg"
+HOMEPAGE="https://pypi.org/project/apipkg/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
 IUSE="examples test"
+RESTRICT="!test? ( test )"
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/hgdistver[${PYTHON_USEDEP}]