*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / anyjson / anyjson-0.3.3-r1.ebuild
index c692047d628e25c789b533a286efdb88d255b96b..b156c5bdc1b6985059730eb640a17997701d32da 100644 (file)
@@ -1,10 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
 
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python2_7 python3_6 )
 
 inherit distutils-r1
 
@@ -16,6 +15,7 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 ~arm64 x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 # please keep all supported implementations in 'test?'
 # to make sure the package is used in the widest way
@@ -23,7 +23,7 @@ DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/simplejson[$(python_gen_usedep 'python2*' python3_3 'pypy*')]
+               dev-python/simplejson[$(python_gen_usedep 'python2*' 'pypy*')]
        )"
 
 python_test() {