*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / CacheControl / CacheControl-0.11.5.ebuild
index 9c13969ca73ce2f9b6315792eafe3ab48f88bf0b..c415fdb1b5eebe62ed19ee7b5090cd554c6c6580 100644 (file)
@@ -1,15 +1,14 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
 
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_COMPAT=( python3_6 pypy3 )
 
 inherit distutils-r1 eutils
 
 DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
-HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
+HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.org/project/cachecontrol/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="MIT"
@@ -20,7 +19,7 @@ IUSE="test"
 RDEPEND="
        dev-python/requests[${PYTHON_USEDEP}]
        >=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
-DEPENDS="${RDEPEND}
+DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/pytest[${PYTHON_USEDEP}]     )
 "