dev-php/pecl-mongodb: bump to 1.5.3
[gentoo.git] / dev-php / pecl-ssh2 / pecl-ssh2-9999.ebuild
index 009cd7eec1f3f22b7eb6c7211bd073b749416fbd..e493a7b71a86733a982581cb1510230b8ddf8494 100644 (file)
@@ -1,19 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=6
 
 PHP_EXT_NAME="ssh2"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
 
-USE_PHP="php7-0 php5-6"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
 EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
 
 inherit php-ext-source-r3 git-r3
 
-USE_PHP="php7-0"
+USE_PHP="php7-0 php7-1 php7-2"
 
 DESCRIPTION="PHP bindings for the libssh2 library"
 LICENSE="PHP-3.01"
@@ -21,17 +18,12 @@ SLOT="7"
 IUSE=""
 KEYWORDS=""
 DEPEND=">=net-libs/libssh2-1.2"
-RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
+RDEPEND="${DEPEND}
+       php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
 HOMEPAGE="https://pecl.php.net/package/ssh2"
-PHP_EXT_ECONF_ARGS=""
-
-src_unpack() {
-       git-r3_src_unpack
-       php-ext-source-r3_src_unpack
-}
 
 src_prepare() {
-       if use php_targets_php7-0 ; then
+       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
                php-ext-source-r3_src_prepare
        else
                default_src_prepare