dev-libs/xapian: version bump to 1.4.14
[gentoo.git] / dev-libs / xapian / xapian-1.4.5.ebuild
index 33e148117ee1d4b18ce04362181d822ea623c419..7012501539addb02074ad0a66d0436c89aa10d97 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -8,12 +8,12 @@ inherit eutils multilib-minimal
 MY_P="${PN}-core-${PV}"
 
 DESCRIPTION="Xapian Probabilistic Information Retrieval library"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+HOMEPAGE="https://www.xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
 
 LICENSE="GPL-2"
 SLOT="0/30" # ABI version of libxapian.so
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc ~x86 ~x64-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sparc x86 ~x64-solaris"
 IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +chert +inmemory"
 
 DEPEND="sys-libs/zlib"
@@ -63,14 +63,11 @@ multilib_src_install() {
 }
 
 multilib_src_install_all() {
-       # bug #573466
-       ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
-
        use doc || rm -rf "${D}usr/share/doc/xapian-core-${PV}"
 
        dodoc AUTHORS HACKING PLATFORMS README NEWS
 
-       prune_libtool_files --all
+       find "${D}" -name "*.la" -type f -delete || die
 }
 
 multilib_src_test() {