dev-libs/weston: Update 9999 line with 3.0.0
[gentoo.git] / dev-libs / weston / weston-9999.ebuild
index c990f2b15ef03f7298e3d8ef872ee2583a25f82c..01cec086558fae378bc8b7695a8285ad1c7c92b4 100644 (file)
@@ -8,10 +8,8 @@ if [[ ${PV} = 9999* ]]; then
        GIT_ECLASS="git-r3"
        EXPERIMENTAL="true"
 fi
-VIRTUALX_REQUIRED="test"
-RESTRICT="test"
 
-inherit autotools readme.gentoo-r1 toolchain-funcs virtualx $GIT_ECLASS
+inherit autotools readme.gentoo-r1 toolchain-funcs $GIT_ECLASS
 
 DESCRIPTION="Wayland reference compositor"
 HOMEPAGE="https://wayland.freedesktop.org/"
@@ -33,29 +31,29 @@ REQUIRED_USE="
        drm? ( gles2 )
        screen-sharing? ( rdp )
        systemd? ( dbus )
-       test? ( X )
+       test? ( headless xwayland )
        wayland-compositor? ( gles2 )
 "
 
 RDEPEND="
        >=dev-libs/libinput-0.8.0
        >=dev-libs/wayland-1.12.0
-       >=dev-libs/wayland-protocols-1.2
+       >=dev-libs/wayland-protocols-1.8
        lcms? ( media-libs/lcms:2 )
        media-libs/libpng:0=
        webp? ( media-libs/libwebp:0= )
        jpeg? ( virtual/jpeg:0= )
        >=x11-libs/cairo-1.11.3
        >=x11-libs/libdrm-2.4.30
-       x11-libs/libxkbcommon
-       x11-libs/pixman
+       >=x11-libs/libxkbcommon-0.5.0
+       >=x11-libs/pixman-0.25.2
        x11-misc/xkeyboard-config
        fbdev? (
                >=sys-libs/mtdev-1.1.0
                >=virtual/udev-136
        )
        colord? ( >=x11-misc/colord-0.1.27 )
-       dbus? ( sys-apps/dbus )
+       dbus? ( >=sys-apps/dbus-1.6 )
        drm? (
                media-libs/mesa[gbm]
                >=sys-libs/mtdev-1.1.0
@@ -68,18 +66,18 @@ RDEPEND="
        rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
        systemd? (
                sys-auth/pambase[systemd]
-               sys-apps/systemd[pam]
+               >=sys-apps/systemd-209[pam]
        )
        launch? ( sys-auth/pambase )
        unwind? ( sys-libs/libunwind )
        X? (
-               x11-libs/libxcb
+               >=x11-libs/libxcb-1.9
                x11-libs/libX11
        )
        xwayland? (
                x11-base/xorg-server[wayland]
                x11-libs/cairo[xcb]
-               x11-libs/libxcb
+               >=x11-libs/libxcb-1.9
                x11-libs/libXcursor
        )
 "
@@ -104,8 +102,6 @@ src_configure() {
                myconf="--disable-simple-clients"
        fi
 
-       myconf+=" --with-cairo=image --disable-simple-egl-clients"
-
        econf \
                $(use_enable examples demo-clients-install) \
                $(use_enable fbdev fbdev-compositor) \
@@ -130,8 +126,12 @@ src_configure() {
                $(use_enable xwayland xwayland-test) \
                $(use_with jpeg) \
                $(use_with webp) \
-               --disable-simple-dmabuf-intel-client \
+               --with-cairo=image \
+               --disable-junit-xml \
+               --disable-simple-dmabuf-drm-client \
                --disable-simple-dmabuf-v4l-client \
+               --disable-simple-egl-clients \
+               --disable-vaapi-recorder \
                ${myconf}
 }
 
@@ -141,7 +141,7 @@ src_test() {
        chmod 0700 "${XDG_RUNTIME_DIR}" || die
 
        cd "${BUILD_DIR}" || die
-       virtx emake check
+       emake check
 }
 
 src_install() {