*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-libs / volume_key / volume_key-0.3.11.ebuild
index 92af05b9da2edadb4bec52e14a8b6d16b7f6880d..e8b891e427ec98d0dc351bd4169c590a71b35abb 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit python-single-r1
 
@@ -13,12 +13,13 @@ SRC_URI="http://releases.pagure.org/${PN}/${P}.tar.xz"
 
 LICENSE="GPL-2+"
 SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm arm64 ia64 ~mips ppc ppc64 sparc x86"
 IUSE="test"
-
+RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="
+       ${PYTHON_DEPS}
        app-crypt/gpgme
        dev-libs/glib:2
        dev-libs/nspr