*/*: Bump copyright on files touched this year
[gentoo.git] / dev-libs / tre / tre-0.8.0-r1.ebuild
index da1592cd388a262bfebd76de2ab12d7c47d043d5..7183d34a9eea19616f915d81d5f0055be4639627 100644 (file)
@@ -1,31 +1,33 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=6
 
 inherit multilib
 
 DESCRIPTION="Lightweight, robust, and efficient POSIX compliant regexp matching library"
-HOMEPAGE="http://laurikari.net/tre/ https://github.com/laurikari/tre/"
-SRC_URI="http://laurikari.net/tre/${P}.tar.bz2"
+HOMEPAGE="https://laurikari.net/tre/ https://github.com/laurikari/tre/"
+SRC_URI="https://laurikari.net/tre/${P}.tar.bz2"
 
 LICENSE="BSD-2"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
 IUSE="nls static-libs"
 
 RDEPEND="
-       !app-misc/glimpse
-       !app-text/agrep"
-DEPEND="${RDEPEND}
+       !app-text/agrep
+       !dev-ruby/amatch
+       !app-misc/glimpse"
+
+DEPEND="
+       ${RDEPEND}
        virtual/pkgconfig
        nls? ( sys-devel/gettext )"
 
+PATCHES=( "${FILESDIR}/${PV}-pkgcfg.patch" )
+
 src_prepare() {
-       eapply \
-               "${FILESDIR}"/${PV}-pkgcfg.patch
-       eapply_user
+       default
 }
 
 src_configure() {
@@ -48,8 +50,10 @@ src_test() {
 
 src_install() {
        local HTML_DOCS=( doc/*.{css,html} )
+
        default
 
+       # 626480
        mv "${ED%/}"/usr/bin/agrep{,-tre}$(get_exeext) || die
 }