sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-libs / opencryptoki / opencryptoki-3.4.1.ebuild
index 53c8192450aed6f7690d1796fccc9d84fb1b6aef..99428ccb4f77641cf28c5c7f0176f2a09aea86ac 100644 (file)
@@ -1,20 +1,19 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI="5"
+EAPI=7
 
 inherit autotools multilib flag-o-matic user
 
 DESCRIPTION="PKCS#11 provider cryptographic hardware"
-HOMEPAGE="http://sourceforge.net/projects/opencryptoki"
+HOMEPAGE="https://sourceforge.net/projects/opencryptoki"
 SRC_URI="mirror://sourceforge/opencryptoki/${PV}/${PN}-v${PV}.tgz"
 
 # Upstream is looking into relicensing it into CPL-1.0 entirely; the CCA
 # token sources are under CPL-1.0 already.
 LICENSE="CPL-0.5"
 SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="~amd64 ~arm ~s390 ~x86"
 IUSE="debug libressl +tpm"
 
 RDEPEND="tpm? ( app-crypt/trousers )
@@ -22,18 +21,24 @@ RDEPEND="tpm? ( app-crypt/trousers )
        libressl? ( dev-libs/libressl:0= )"
 DEPEND="${RDEPEND}"
 
-S="${WORKDIR}/${PN}"
+DOCS=(
+       README AUTHORS FAQ TODO
+       doc/openCryptoki-HOWTO.pdf
+)
 
 # tests right now basically don't exist; the only available thing would
 # test against an installed copy and would kill a running pcscd, all
 # things that we're not interested to.
 RESTRICT=test
 
+S="${WORKDIR}/${PN}"
+
 pkg_setup() {
        enewgroup pkcs11
 }
 
 src_prepare() {
+       default
        mv configure.in configure.ac || die
        eautoreconf
 }
@@ -58,7 +63,6 @@ src_configure() {
        econf \
                --localstatedir=/var \
                --enable-fast-install \
-               --disable-dependency-tracking \
                --disable-debug \
                --enable-daemon \
                --enable-library \
@@ -69,23 +73,21 @@ src_configure() {
 }
 
 src_install() {
-       emake install DESTDIR="${ED}"
+       default
+       find "${ED}" -name '*.la' -delete || die
 
        # Install libopencryptoki in the standard directory for libraries.
-       mv "${D}"/usr/$(get_libdir)/opencryptoki/libopencryptoki.so* "${D}"/usr/$(get_libdir) || die
-       rm "${D}"/usr/$(get_libdir)/pkcs11/libopencryptoki.so
+       mv "${ED}"/usr/$(get_libdir)/opencryptoki/libopencryptoki.so* "${ED}"/usr/$(get_libdir) || die
+       rm "${ED}"/usr/$(get_libdir)/pkcs11/libopencryptoki.so
        dosym ../libopencryptoki.so /usr/$(get_libdir)/pkcs11/libopencryptoki.so
 
        # Remove compatibility symlinks as we _never_ required those and
        # they seem unused even upstream.
-       find "${D}" -name 'PKCS11_*' -delete
-
-       # doesn't use libltdl; only dlopen()-based interfaces
-       find "${D}" -name '*.la' -delete
+       find "${ED}" -name 'PKCS11_*' -delete
 
        # We replace their ld.so and init files (mostly designed for RedHat
        # as far as I can tell) with our own replacements.
-       rm -rf "${D}"/etc/ld.so.conf.d "${D}"/etc/rc.d
+       rm -rf "${ED}"/etc/ld.so.conf.d "${ED}"/etc/rc.d
 
        # make sure that we don't modify the init script if the USE flags
        # are enabled for the needed services.
@@ -95,7 +97,5 @@ src_install() {
 
        # We create /var dirs at runtime as needed, so don't bother installing
        # our own.
-       rm -r "${D}"/var/{lib,lock} || die
-
-       dodoc README AUTHORS FAQ TODO doc/openCryptoki-HOWTO.pdf
+       rm -r "${ED}"/var/{lib,lock} || die
 }