sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-libs / go-fuse / go-fuse-0_p20140812-r1.ebuild
index eb4bbe604de0cae5f59c09c956f87d9fdf872006..b962c085f6b55c36eefbb1c999a7da67a86c0551 100644 (file)
@@ -1,21 +1,27 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
 
-KEYWORDS="~amd64"
-RESTRICT="strip"
-DESCRIPTION="FUSE bindings for Go"
+inherit eutils vcs-clean
+
 GO_PN=github.com/hanwen/${PN}
-HOMEPAGE="https://${GO_PN}"
 EGIT_COMMIT="8c85ded140ac1889372a0e22d8d21e3d10a303bd"
+
+HOMEPAGE="https://github.com/hanwen/go-fuse"
+DESCRIPTION="FUSE bindings for Go"
 SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
+
 SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
 IUSE=""
+
 DEPEND=">=dev-lang/go-1.3"
 RDEPEND=""
+
+RESTRICT="strip"
+
 S=${WORKDIR}
 
 src_unpack() {
@@ -47,6 +53,6 @@ src_install() {
        doins -r pkg
        insinto /usr/lib/go/src
        rm src/${GO_PN}/all.bash.patched || die
-       find src/${GO_PN} -name .gitignore -delete
+       egit_clean src/${GO_PN}
        doins -r src/*
 }