*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-lang / spidermonkey / spidermonkey-52.9.1_pre1.ebuild
index cadf22413d78f89cd5ee96690965a7dd1501da78..825f583c637af6b8a07ed62ed2bbe9016202b852 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -16,10 +16,10 @@ SRC_URI="http://ftp.mozilla.org/pub/spidermonkey/prereleases/52/pre1/mozjs-52.9.
 
 LICENSE="NPL-1.1"
 SLOT="52"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 s390 x86"
 IUSE="debug minimal +system-icu test"
 
-RESTRICT="ia64? ( test )"
+RESTRICT="!test? ( test ) ia64? ( test )"
 
 S="${WORKDIR}/${MY_P%.rc*}"
 BUILDDIR="${S}/jsobj"
@@ -31,7 +31,7 @@ RDEPEND=">=dev-libs/nspr-4.13.1
        system-icu? ( >=dev-libs/icu-58.1:= )"
 DEPEND="${RDEPEND}"
 
-pkg_setup(){
+pkg_setup() {
        [[ ${MERGE_TYPE} == "binary" ]] || \
                moz_pkgsetup
 
@@ -48,7 +48,8 @@ src_prepare() {
 
        eapply "${WORKDIR}/${PN}"
        eapply "${FILESDIR}"/moz38-dont-hardcode-libc-soname.patch
-       #eapply "${FILESDIR}"/${PN}-52-baseconfig.patch
+       eapply "${FILESDIR}"/${PN}-52.0-fix-alpha-bitness.patch
+       eapply "${FILESDIR}"/${PN}-52.0-gcc9-overflow.patch
 
        eapply_user
 
@@ -77,6 +78,7 @@ src_configure() {
                --with-system-nspr \
                --disable-optimize \
                --with-intl-api \
+               --disable-gold \
                $(use_with system-icu) \
                $(use_enable debug) \
                $(use_enable test tests) \