*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-lang / spidermonkey / spidermonkey-17.0.0-r5.ebuild
index 6a67fe8f8d5a9d2cffc60a01501c81857ccfef8f..7f28ec8e9d69554d23720cfd699cd2c09ea07f22 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -17,11 +17,11 @@ SRC_URI="http://archive.mozilla.org/pub/js/${MY_PN}${PV}.tar.gz
 LICENSE="NPL-1.1"
 SLOT="17"
 # "MIPS, MacroAssembler is not supported" wrt #491294 for -mips
-KEYWORDS="~alpha ~amd64 ~arm -hppa ia64 -mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm -hppa ia64 -mips ppc ppc64 ~s390 ~sparc x86"
 IUSE="debug jit minimal static-libs test"
 
 REQUIRED_USE="debug? ( jit )"
-RESTRICT="ia64? ( test )"
+RESTRICT="!test? ( test ) ia64? ( test )"
 
 S="${WORKDIR}/${MY_P}"
 BUILDDIR="${S}/js/src"
@@ -35,7 +35,7 @@ DEPEND="${RDEPEND}
        app-arch/zip
        virtual/pkgconfig"
 
-pkg_setup(){
+pkg_setup() {
        if [[ ${MERGE_TYPE} != "binary" ]]; then
                python-any-r1_pkg_setup
                export LC_ALL="C"