dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / quickcheck / quickcheck-2.8.2.ebuild
index 1fbf2770815072892f1a0df72f5c237d42c105e3..ec26c134abb7dff92f1e699ef126f09fcffc0bbd 100644 (file)
@@ -1,11 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
 
 # ebuild generated by hackport 0.4.6.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
 
 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
 inherit haskell-cabal
@@ -15,12 +14,12 @@ MY_P="${MY_PN}-${PV}"
 
 DESCRIPTION="Automatic testing of Haskell programs"
 HOMEPAGE="https://github.com/nick8325/quickcheck"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="2/${PV}"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux"
+IUSE="+template-haskell"
 
 RESTRICT=test # to avoid test circular depends
 
@@ -40,5 +39,5 @@ src_configure() {
        haskell-cabal_src_configure \
                --flag=-base3 \
                --flag=base4 \
-               $(cabal_flag template_haskell templatehaskell)
+               $(cabal_flag template-haskell templatehaskell)
 }