dev-python/objgraph: keyworded 3.4.1 for ia64, bug #717946
[gentoo.git] / dev-haskell / pandoc-citeproc / pandoc-citeproc-0.7.2.ebuild
index d01863694193fefcd4effd181826b899c29f3bf7..ab931f4393f0e5561107c3de94fea2b9b04545ce 100644 (file)
@@ -1,6 +1,5 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
 
@@ -12,12 +11,12 @@ inherit haskell-cabal
 
 DESCRIPTION="Supports using pandoc with citeproc"
 HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0/${PV}"
-KEYWORDS="amd64 x86"
-IUSE="+bibutils debug embed_data_files test_citeproc unicode_collation"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils debug embed-data-files test-citeproc unicode_collation"
 
 RESTRICT=test # fd:8: hClose: resource vanished (Broken pipe)
 
@@ -57,8 +56,8 @@ src_configure() {
        haskell-cabal_src_configure \
                $(cabal_flag bibutils bibutils) \
                $(cabal_flag debug debug) \
-               $(cabal_flag embed_data_files embed_data_files) \
+               $(cabal_flag embed-data-files embed_data_files) \
                --flag=-small_base \
-               $(cabal_flag test_citeproc test_citeproc) \
+               $(cabal_flag test-citeproc test-citeproc) \
                $(cabal_flag unicode_collation unicode_collation)
 }