dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / alex / alex-3.1.7.ebuild
index 655ae146408a9b68eb5ec15cc1a7ccc5e581c127..f74adcaf449507ea0ed7c0a7978d03e853edb012 100644 (file)
@@ -1,6 +1,5 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
 
@@ -12,11 +11,11 @@ inherit autotools eutils haskell-cabal
 
 DESCRIPTION="Alex is a tool for generating lexical analysers in Haskell"
 HOMEPAGE="http://www.haskell.org/alex/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
 IUSE="doc"
 
 RDEPEND=">=dev-haskell/quickcheck-2:2=
@@ -67,7 +66,7 @@ src_compile() {
 
 src_test() {
        # workaround https://github.com/haskell/cabal/issues/2398
-       emake -k -C tests all || die
+       emake -k -C tests all
 }
 
 src_install() {