x11-drivers/xf86-input-libinput: sparc stable wrt bug #620234
[gentoo.git] / dev-erlang / lager / lager-3.2.0.ebuild
index 4a3dd911373717c1964c1c0cdaabaad733962c32..3c88ed5979cbdfd904c55b79d0ca11e5ecefccee 100644 (file)
@@ -1,6 +1,5 @@
 # Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=6
 
@@ -13,7 +12,7 @@ SRC_URI="https://github.com/basho/${PN}/archive/${PV}.tar.gz
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
 
 DEPEND=">=dev-erlang/goldrush-0.1.7
        >=dev-lang/erlang-17.1"
@@ -21,15 +20,15 @@ RDEPEND="${DEPEND}"
 
 DOCS=( README.md TODO )
 PATCHES=(
-       "${FILESDIR}/0001-Support-typed-records-newly-exposed-in-OTP-19.patch"
-       "${FILESDIR}/0002-Fix-get_env-bug.patch"
-       "${FILESDIR}/0003-Add-get_env-unit-test.patch"
-       "${FILESDIR}/0004-Undo-unnecessary-whitespace.patch"
-       "${FILESDIR}/0005-R15-does-not-appear-to-properly-handle-the-export.patch"
+       "${FILESDIR}/${PV}-0001-Support-typed-records-newly-exposed-in-OTP-19.patch"
+       "${FILESDIR}/${PV}-0002-Fix-get_env-bug.patch"
+       "${FILESDIR}/${PV}-0003-Add-get_env-unit-test.patch"
+       "${FILESDIR}/${PV}-0004-Undo-unnecessary-whitespace.patch"
+       "${FILESDIR}/${PV}-0005-R15-does-not-appear-to-properly-handle-the-export.patch"
 )
 
 src_prepare() {
        rebar_src_prepare
        # 'priv' directory contains only edoc.css, but doc isn't going to be built.
-       rm -r "${S}/priv"
+       rm -r "${S}/priv" || die
 }