sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-embedded / sdcc / sdcc-3.8.0-r1.ebuild
index abba11e8b886750de99827f5ff0f66bdae6d13e7..c4850e61728973cfa8c2d5c98d32c596fde3c662 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -12,7 +12,7 @@ else
                mirror://sourceforge/sdcc/${PN}-src-${PV}.tar.bz2
                doc? ( mirror://sourceforge/sdcc/${PN}-doc-${PV}.tar.bz2 )
        "
-       KEYWORDS="~amd64 ~x86"
+       KEYWORDS="amd64 x86"
 fi
 
 DESCRIPTION="Small device C compiler (for various microprocessors)"
@@ -68,17 +68,16 @@ src_prepare() {
                        -e 's:\<(PORTDIR|ARCH)\>:SDCC\1:g' \
                        {} + || die
 
-       # https://sourceforge.net/p/sdcc/bugs/2398/
-       sed -i -e '1iAR = @AR@' Makefile.common.in || die
-       sed -i \
-               -e "/^AR =/s:=.*:=$(tc-getAR):" \
-               support/cpp/Makefile.in || die
-
        # Make sure timestamps don't get messed up.
        [[ ${PV} == "9999" ]] && find "${S}" -type f -exec touch -r . {} +
 
        default
        eautoreconf
+
+       # Avoid 'bfd.info' rebuild with 'makeinfo': bug #705424
+       # Build dependencies are: eautoreconf->Makefile.in->bfdver.texi->bfd.info
+       touch support/sdbinutils/bfd/doc/bfdver.texi || die
+       touch support/sdbinutils/bfd/doc/bfd.info || die
 }
 
 src_configure() {
@@ -112,7 +111,6 @@ src_configure() {
                $(use_enable z180 z180-port) \
                $(use_enable z80 z80-port) \
                --disable-doc \
-               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
                --without-ccache
 }
 
@@ -129,5 +127,5 @@ src_install() {
        # a bunch of archives (*.a) are built & installed by gputils
        # for PIC processors, but they do not work with standard `ar`
        # & `scanelf` utils and they're not for the host.
-       dostrip "${D%/}"/usr/bin
+       dostrip /usr/bin
 }