*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-cpp / gtest / gtest-1.9.0_pre20190607.ebuild
index 9fc545d7fd83a42719cca608c369c1e16ee43d2e..3f9846728ea7dad7cf25dddfe8b08b4222b9f0c2 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
 # Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_COMPAT=( python2_7 )
 
+CMAKE_ECLASS=cmake
 GOOGLETEST_COMMIT=da10da05c262af0a9e8fa91789a272a3dec67655
-
 inherit cmake-multilib python-any-r1
 
 if [[ ${PV} == "9999" ]]; then
@@ -20,7 +20,7 @@ else
                MY_PV=${GOOGLETEST_COMMIT}
        fi
        SRC_URI="https://github.com/google/googletest/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+       KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
        S="${WORKDIR}"/googletest-${MY_PV}
 fi
 
@@ -30,12 +30,13 @@ HOMEPAGE="https://github.com/google/googletest"
 LICENSE="BSD"
 SLOT="0"
 IUSE="doc examples test"
+RESTRICT="!test? ( test )"
 
 DEPEND="test? ( ${PYTHON_DEPS} )"
 RDEPEND="!dev-cpp/gmock"
 
 PATCHES=(
-       "${FILESDIR}"/${PN}-1.9.0_pre20190607-add-mmap-stack-flag.patch
+       "${FILESDIR}"/${PN}-1.9.0_pre20190607-increase-clone-stack-size.patch
 )
 
 pkg_setup() {
@@ -43,7 +44,7 @@ pkg_setup() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -i -e '/set(cxx_base_flags /s:-Werror::' \
                googletest/cmake/internal_utils.cmake || die "sed failed!"
@@ -59,7 +60,7 @@ multilib_src_configure() {
                -Dgtest_build_tests=$(usex test)
                -DPYTHON_EXECUTABLE="${PYTHON}"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_install_all() {