app-shells/rrs: bump EAPI to 7, fix building with openssl 1.1
[gentoo.git] / app-shells / rrs / rrs-1.70-r2.ebuild
index efc3d8c7394fb413ee888c4bb64883b868633571..0af183bb953f3fb27d222dcd6a75a596fd1f9f58 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit toolchain-funcs
 
@@ -12,12 +12,16 @@ SRC_URI="http://www.cycom.se/uploads/36/19/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 ppc x86"
+
 IUSE="ssl"
 
 DEPEND="ssl? ( dev-libs/openssl:0= )"
 RDEPEND="${DEPEND}"
 
-PATCHES=( "${FILESDIR}"/"${P}"-asneeded.patch )
+PATCHES=(
+       "${FILESDIR}/${P}-asneeded.patch"
+       "${FILESDIR}/${P}-drop-old-ssl-algos.patch"
+)
 
 src_prepare() {
        default